<!doctype html>
<html lang="en">
<head>
<meta name="distribution" content="global" />
<meta name="robots" content="follow, all" />
 <meta content="text/html; charset=UTF-8" http-equiv="Content-Type" />
 <meta name="google-site-verification" content="XrACasD3S_CQnP2yJxxl5S9YRLFohKRD4XKOd35jL0Q" />
 <meta name="msvalidate.01" content="8D3F505D642C99EB26E45507554512BC" />
 

<meta name="viewport" content="width=device-width, initial-scale=1.0">

<!-- Escape from Frames-->
<script type="text/javascript">if(self==top){document.documentElement.style.display="block"}else{top.location=self.location}</script> 
<link href="https://fonts.googleapis.com/css2?family=Lato&family=Open+Sans&display=swap" rel="stylesheet">

<link rel="stylesheet" href="https://redmondregister.com/wp-content/themes/newsalambre/style.css?1583515401" type="text/css" media="screen, projection" />

<link href="https://redmondregister.com/feed" rel="alternate" title="Redmond Register RSS Feed" type="application/rss+xml" />
<link href="https://redmondregister.com/feed/atom" rel="alternate" title="Redmond Register Atom Feed" type="application/atom+xml" />
<link href="https://redmondregister.com/xmlrpc.php" rel="pingback" />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://redmondregister.com/wp-includes/css/dist/block-library/style.min.css?ver=5.1.4' type='text/css' media='all' />
<link rel='https://api.w.org/' href='https://redmondregister.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://redmondregister.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://redmondregister.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='ProShare Advisors LLC Buys 648 Shares of Dorman Products Inc. (NASDAQ:DORM)' href='https://redmondregister.com/2020/03/23/proshare-advisors-llc-buys-648-shares-of-dorman-products-inc-nasdaqdorm.html' />
<link rel='next' title='SPX Flow Inc (NYSE:FLOW) Shares Bought by ProShare Advisors LLC' href='https://redmondregister.com/2020/03/23/spx-flow-inc-nyseflow-shares-bought-by-proshare-advisors-llc.html' />
<meta name="generator" content="WordPress 5.1.4" />
<link rel="canonical" href="https://redmondregister.com/2020/03/23/proshare-advisors-llc-raises-position-in-evertec-inc-nyseevtc.html" />
<link rel='shortlink' href='https://redmondregister.com/?p=89835' />
<link rel="alternate" type="application/json+oembed" href="https://redmondregister.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fredmondregister.com%2F2020%2F03%2F23%2Fproshare-advisors-llc-raises-position-in-evertec-inc-nyseevtc.html" />
<link rel="alternate" type="text/xml+oembed" href="https://redmondregister.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fredmondregister.com%2F2020%2F03%2F23%2Fproshare-advisors-llc-raises-position-in-evertec-inc-nyseevtc.html&#038;format=xml" />
<!-- HFCM by 99 Robots - Snippet # 1:  -->
<meta name="google-site-verification" content="5FDBvT74Ot-gkl4C_oMtZZicU3osLOMmLuweGcOPqAw" />
<!-- /end HFCM by 99 Robots -->
<link rel="amphtml" href="https://redmondregister.com/2020/03/23/proshare-advisors-llc-raises-position-in-evertec-inc-nyseevtc.html/amp" /><link rel="icon" href="https://redmondregister.com/wp-content/uploads/2020/03/redmond-register-256-t-115x115.png" sizes="32x32" />
<link rel="icon" href="https://redmondregister.com/wp-content/uploads/2020/03/redmond-register-256-t.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://redmondregister.com/wp-content/uploads/2020/03/redmond-register-256-t.png" />
<meta name="msapplication-TileImage" content="https://redmondregister.com/wp-content/uploads/2020/03/redmond-register-256-t.png" />

<!-- Start Meta Data -->
<title>ProShare Advisors LLC Raises Position in Evertec Inc (NYSE:EVTC) - Redmond Register</title>
<meta name="distribution" content="global" />
<meta name="robots" content="follow, all" />
<meta name="description" content="ProShare Advisors LLC lifted its stake in shares of Evertec Inc (NYSE:EVTC) by 17.1% in the 4th quarter, according to the company in its most recent 13F filing with the Securities &amp; Exchange Commission. The fund owned 9,864 shares of the business services provider&#8217;s stock after purchasing an additional 1,444 shares during the period. ProShare [&hellip;]" />
<meta name="author" content="Benjamin Ortiz">
<meta name="news_keywords" content="Evertec,NYSE:EVTC,EVTC,Business Service,SEC Filings,13F,Hedge Fund Holdings,Institutional Investor Holdings" />
<meta name="keywords" content="Evertec,NYSE:EVTC,EVTC,Business Service,SEC Filings,13F,Hedge Fund Holdings,Institutional Investor Holdings" />
<meta name="ticker" content="NYSE:EVTC" />
<meta name="contentType" content="article">

<!-- Twitter Card Data -->
<meta name="twitter:card" content="summary"/>
<meta name="twitter:site" content="@RatingsNetwork" />
<meta name="twitter:title" content="ProShare Advisors LLC Raises Position in Evertec Inc (NYSE:EVTC)"/>
<meta name="twitter:description" content="ProShare Advisors LLC lifted its stake in shares of Evertec Inc (NYSE:EVTC) by 17.1% in the 4th quarter, according to the company in its most recent 13F filing with the Securities &amp; Exchange Commission. The fund owned 9,864 shares of the business services provider&#8217;s stock after purchasing an additional 1,444 shares during the period. ProShare [&hellip;]" />
<meta name="twitter:creator" content="@RatingsNetwork" />
<meta name="twitter:image" content="https://www.marketbeat.com/logos/evertec-inc-logo.jpg" />

<!-- Open Graph Data -->
<meta property="og:title" content="ProShare Advisors LLC Raises Position in Evertec Inc (NYSE:EVTC)" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://redmondregister.com/2020/03/23/proshare-advisors-llc-raises-position-in-evertec-inc-nyseevtc.html" />
<meta property="og:image" content="https://www.marketbeat.com/logos/evertec-inc-logo.jpg" />
<meta property="og:description" content="ProShare Advisors LLC lifted its stake in shares of Evertec Inc (NYSE:EVTC) by 17.1% in the 4th quarter, according to the company in its most recent 13F filing with the Securities &amp; Exchange Commission. The fund owned 9,864 shares of the business services provider&#8217;s stock after purchasing an additional 1,444 shares during the period. ProShare [&hellip;]" />
<meta property="og:site_name" content="Redmond Register" />
<meta property="og:locale" content="en_US" />

<!-- OG Article Template -->
<meta property="article:published_time" content="2020-03-23T05:30:49+0000" />
<meta property="article:modified_time" content="2020-03-23T05:30:49+0000" />
<meta property="article:tag" content="NYSE:EVTC" />
<meta property="article:tag" content="Evertec,NYSE:EVTC,EVTC,Business Service,SEC Filings,13F,Hedge Fund Holdings,Institutional Investor Holdings" />
<meta property="article:section" content="Markets" />

<!-- Google meta is in the body-->

<!-- End Meta Data -->

	
<script type='text/javascript'>var PopupAdChannel=''; </script>

  <link rel="manifest" href="/manifest.json">
  <script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js"></script>
  <script>
  	function registerUserChange(action) {
		OneSignal.getUserId( function(userId) {
			OneSignalIdString = userId;
			var Domain = 'redmondregister.com';
			var url = "https://www.marketbeat.com/scripts/OneSignalTracking.ashx?OneSignalID=" + OneSignalIdString + "&domain=" + Domain + "&action=" + action;
			var xhr = new XMLHttpRequest();
			xhr.open('GET', url);
			xhr.onload = function () {
				if (xhr.status !== 200) {
					console.log('GET failed.  Returned status of ' + xhr.status);
				}
			};
			xhr.send();
		});
	}
    var OneSignal = window.OneSignal || [];
    OneSignal.push(["init", {
      appId: "2b4435ec-8414-4fd7-822a-ff3ff67bedb4",
      safari_web_id: 'web.onesignal.auto.449e8e5d-df22-4f65-ad52-0d8b06e9cdb9', 
      autoRegister: false,
      notifyButton: {
        enable: false /* Set to false to hide */
      },
 welcomeNotification: {
        "title": "Join Wall Street's Brightest Minds.",
        "message": "Receive research in your inbox from top analysts, before the market opens. Click here to learn how.",
         "url": "https://www.marketbeat.com/subscribe/subscribe.aspx?ReferralType=OneSignalThankYou&ProductCode=1997t"
    }
    },
		OneSignal.once('subscriptionChange', function (isSubscribed) {
			if(isSubscribed) {
				registerUserChange("subscribe");
			}
			else {
				registerUserChange("unsubscribe");
			}
			
		  })
	]);
if((navigator.userAgent.toLowerCase().indexOf('firefox') > -1)||((navigator.userAgent.toLowerCase().indexOf('safari') > -1)&&(!(navigator.userAgent.toLowerCase().indexOf('chrome') > -1)))){
		OneSignal.showSlidedownPrompt();
	} else {
		OneSignal.showNativePrompt();		
	}  </script>



<script type="text/javascript">var vbnfgha = '211626'; var ertdfga = '13739-bup-ac'; var qhyuioa = '53938'; var AdClientID = qhyuioa + vbnfgha + ertdfga; AdClientID = AdClientID.split("").reverse().join("");</script>

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: AdClientID,
          enable_page_level_ads: true
     });
</script>

	
<!-- ims -->
	
<script type="text/javascript">
		var apntag = apntag || {};
		apntag.anq = apntag.anq || [];
		(function() {
			var d = document, e = d.createElement('script'), p = d.getElementsByTagName('head')[0];
			e.type = 'text/javascript';  e.async = true;
			e.src = '//acdn.adnxs.com/ast/ast.js';
			p.insertBefore(e, p.firstChild);
		})();

		
		apntag.anq.push(function() {
			apntag.setPageOpts({
				member: 6989
			});
		});

		apntag.anq.push(function() {

      		apntag.defineTag({
				tagId: 13685730,
				sizes: [[300,250]],
				keywords: {'position': ['RightRail_1']},
				targetId: 'RedmondRegister_ROS_RightRail_1'
			});

		apntag.anq.push(function() {
			apntag.loadTags();
		});
			});
		</script>
	
	<script type="text/javascript">
(function() {
window.advBidxc = window.advBidxc || {};
window.advBidxc.startTime = new Date().getTime();
function loadScript(tagSrc) {
var scriptTag = document.createElement('script'),
placeTag = document.getElementsByTagName("script")[0];
scriptTag.type = 'text/javascript';
scriptTag.async = true;
scriptTag.src = tagSrc;
placeTag.parentNode.insertBefore(scriptTag, placeTag);
}
var mnSrc = '//hbx.media.net/bidexchange.js?cid=8CU2C156D&version=5.1' + '&dn=' +
window.location.hostname;
loadScript(mnSrc);
})();
</script>
	<!-- ims -->
	
	
	
	<script type="text/javascript" src="https://www.marketbeat.com/Scripts/lowerrightad.js?v=9"></script>
	
<!-- Gemini Dot Tag -->
<script type="application/javascript">(function(w,d,t,r,u){w[u]=w[u]||[];w[u].push({'projectId':'10000','properties':{'pixelId':'423827'}});var s=d.createElement(t);s.src=r;s.async=true;s.onload=s.onreadystatechange=function(){var y,rs=this.readyState,c=w[u];if(rs&&rs!="complete"&&rs!="loaded"){return}try{y=YAHOO.ywa.I13N.fireBeacon;w[u]=[];w[u].push=function(p){y([p])};y(c)}catch(e){}};var scr=d.getElementsByTagName(t)[0],par=scr.parentNode;par.insertBefore(s,scr)})(window,document,"script","https://s.yimg.com/wi/ytc.js","dotq");</script>

</head>
<body>
<div id="wrap">

<!-- Start MarketBeat Modern Popup -->
<link rel="stylesheet" type="text/css" media="all" href="https://www.marketbeat.com/scripts/modal/modernpopup.css?v=11"/>
<script type="text/javascript" src="https://www.marketbeat.com/scripts/modal/modernpopup.js?v=52"></script>

	<script type="text/javascript">LoadPopupRatings('ModernMarketsPopup-Redmond Register', 'redmondregister.com', 'NYSE:EVTC', 'Evertec', 'https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?w=175&zc=1&src=https://www.marketbeat.com/logos/evertec-inc-logo.jpg');</script>
	<!-- End MarketBeat Modern Popup -->
	

<header>
	
	<div class="width-limiter add-padding flex-container"><!-- start: width-limiter with logo and space for alternate header unit -->
		<a class="logo-link flex-logo" href="https://redmondregister.com"><img id="logo" src="https://redmondregister.com/wp-content/uploads/2020/03/redmond-register-06.png" alt="Redmond Register logo"></a>

<!-- Begin Header Unit -->
<div id="AlternateHeaderUnit" class="flex-header-ad">
<iframe class="large-show" src="https://marketbeat.com/scripts/HeaderAdNewsSites.ashx" width="728" height="90" frameborder="no" scrolling="no" style="overflow:hidden;"></iframe>
	<iframe class="small-show" src="https://marketbeat.com/scripts/SidebarAdNewsSites.ashx" width="336" height="280" frameborder="no"scrolling="no" style="overflow:hidden;margin:0 auto;"></iframe>
</div> 

<!-- End Header Unit-->
	</div> <!-- end: width-limiter with logo and space for alternate header unit -->
	<div id="menu">
		<div class="width-limiter flex-container" id="nav-main">
			
			
                    <label for="nav-trigger">&#9776;</label>
                	<input type="checkbox" id="nav-trigger" class="navOpen" />
                
                	<div class="mobile-nav">
                		<nav id="main-sections-nav" class="sitenav">
                			
                			<nav class="mobile-menu"><ul id="menu-menu-1" class="menu"><li id="menu-item-18" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18"><a href="https://redmondregister.com/headlines">Headlines</a></li>
<li id="menu-item-16" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16"><a href="https://redmondregister.com/business">Business</a></li>
<li id="menu-item-17" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17"><a href="https://redmondregister.com/economy">Economy</a></li>
<li id="menu-item-19" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19"><a href="https://redmondregister.com/health">Health</a></li>
<li id="menu-item-20" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-20"><a href="https://redmondregister.com/technology">Technology</a></li>
<li id="menu-item-14" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-14"><a href="https://redmondregister.com/about-contact">Contact</a></li>
<li id="menu-item-15" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15"><a href="https://redmondregister.com/privacy-policy">Policies</a></li>
</ul></nav>                			
                			<form class="mobile-search" id="mobileSearchForm" action="https://redmondregister.com/" method="get">
                				<div id="search">
                					<input id="s" class="searchinput" name="s" onclick="this.value='';" type="text" />
                					<input class="searchsubmit" type="submit" value="⌕" />
                				</div>
                			</form>
                		</nav>
                	</div>
                	<!-- <label for="nav-trigger" id="navthing"></label> -->
                    
             
			
			<!-- start main category menu -->
			
			<div class="flex-nav">
			   
			  



			<nav class="navigation"><ul id="menu-menu-2" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18"><a href="https://redmondregister.com/headlines">Headlines</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16"><a href="https://redmondregister.com/business">Business</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17"><a href="https://redmondregister.com/economy">Economy</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19"><a href="https://redmondregister.com/health">Health</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-20"><a href="https://redmondregister.com/technology">Technology</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-14"><a href="https://redmondregister.com/about-contact">Contact</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15"><a href="https://redmondregister.com/privacy-policy">Policies</a></li>
</ul></nav>			
			</div>
				<form class="flex-search" id="searchform" action="https://redmondregister.com/" method="get">
					<div id="search">
						<input id="s" class="searchinput" name="s" onclick="this.value='';" type="text" />
						<input class="searchsubmit" type="submit" value="⌕" />
					</div>
					
				</form><!-- end: searchform -->
		</div> <!-- end: width-limiter for menu -->
	</div> <!-- end: menu -->
</header> <!-- end: header -->
	<div class="width-limiter main-content flex-container">
		

		<main class="flex-main">
			 <article itemscope itemtype="http://schema.org/NewsArticle">
				
				<link itemprop="mainEntityOfPage" href="https://redmondregister.com/2020/03/23/proshare-advisors-llc-raises-position-in-evertec-inc-nyseevtc.html" />
				<h1 itemprop="headline" class="page-title">ProShare Advisors LLC Raises Position in Evertec Inc (NYSE:EVTC)</h1>
				
				<p class="postmeta">
					Posted by <span itemprop="author" itemscope itemtype="https://schema.org/Person"><span itemprop="name"><a href="https://redmondregister.com/author/Benjamin%20Ortiz" title="Posts by Benjamin Ortiz" rel="author">Benjamin Ortiz</a></span></span> on <span itemprop="datePublished dateModified" content="2020-03-23T05:30:49+0000">Mar 23rd, 2020</span>
				</p><!--end .postmeta-->
				<!--sse-->
				<div class="entry" itemprop="articleBody"> 
				<!-- start main text -->
					
					<p><img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?w=250&zc=1&src=https://www.marketbeat.com/logos/evertec-inc-logo.jpg" alt="Evertec logo" title="Evertec logo" class="companylogo" />ProShare Advisors LLC lifted its stake in shares of  Evertec Inc (NYSE:EVTC) by 17.1% in the 4th quarter, according to the company in its most recent 13F filing with the Securities &amp; Exchange Commission. The fund owned 9,864 shares of the business services provider&#8217;s stock after purchasing an additional 1,444 shares during the period. ProShare Advisors LLC&#8217;s holdings in Evertec were worth $336,000 at the end of the most recent quarter. </p>
<p>Several other hedge funds also recently modified their holdings of the company. Municipal Employees Retirement System of Michigan increased its position in shares of  Evertec by 2.0% in the fourth quarter. Municipal Employees Retirement System of Michigan now owns 18,270 shares of the business services provider&#8217;s stock valued at $622,000 after acquiring an additional 360 shares during the period.  Nisa Investment Advisors LLC lifted its stake in shares of  Evertec by 86.2% in the fourth quarter. Nisa Investment Advisors LLC now owns 1,080 shares of the business services provider&#8217;s stock worth $37,000 after buying an additional 500 shares in the last quarter.  Bessemer Group Inc. lifted its stake in shares of  Evertec by 0.4% in the fourth quarter. Bessemer Group Inc. now owns 147,958 shares of the business services provider&#8217;s stock worth $5,036,000 after buying an additional 560 shares in the last quarter.  Yorktown Management &#038; Research Co Inc lifted its stake in shares of  Evertec by 4.7% in the fourth quarter. Yorktown Management &#038; Research Co Inc now owns 22,100 shares of the business services provider&#8217;s stock worth $752,000 after buying an additional 1,000 shares in the last quarter.  Finally, FIL Ltd bought a new position in shares of  Evertec in the fourth quarter worth approximately $34,000. Institutional investors own  81.49% of the company&#8217;s stock. </p>
<form method="get" action="https://www.marketbeat.com/newsletter/default.aspx" style="border-bottom-width: 1px; border-color: #D2D2D2; border-style: solid; border-top-width: 1px; margin-bottom: 24px; margin-top: 12px; padding: 12px 0;border-right:none;border-left:none;clear:both;">
    <input type="hidden" id="Hidden1" name="RegistrationCode" value="InPost-Redmond Register"  />
    <input type="hidden" id="Hidden2" name="RegisterTicker" value="NYSE:EVTC" />    <label for="InPostRegistrationEmail">Get <b>Evertec</b> alerts:</label>
    <div style="display:inline-block;"><input id="InPostRegistrationEmail" name="RegisterEmail" type="email" placeholder="Enter Your Email Address" style="border: 1px solid #D2D2D2;font-size: 12px;line-height: 18px;margin: 0;min-width: 200px; padding: 4px;" /><input type="submit" name="submit" onclick="return CheckEmail('InPostRegistrationEmail','ShowSuggestionInPost');" value="Submit" style="-webkit-appearance: none;-moz-appearance: none;appearance: none;background-color: #1361A2;border: 1px solid #1361A2;border-bottom-right-radius: .5em;border-top-right-radius: .5em;color: #fff;font-size: 12px;font-weight: 700;line-height: 18px;padding: 4px 18px"></div>
</form>
<div id="ShowSuggestionInPost"></div>


<p>Separately, <a style='font-weight:bold' href='http://www.americanconsumernews.net/scripts/click.aspx?Zacks=1'>Zacks Investment Research</a> downgraded shares of Evertec from a &#8220;hold&#8221; rating to a &#8220;strong sell&#8221; rating in a research report on Friday, February 28th.</p>
<p>
		  <div class="in-article-ad" class="width:340px;">
		<!-- Network Wide AdSense Unit - In-Post Position -->
<ins class="adsbygoogle" style="display:block; text-align:center;" data-ad-layout="in-article" data-ad-format="fluid" data-ad-client="ca-pub-9373162611283935" data-ad-slot="9254111670"></ins>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script>
<!-- End AdSense Unit -->
</div>


                 Shares of <a href='https://www.marketbeat.com/stocks/NYSE/EVTC/sec-filings/' target='_blank' rel="noopener noreferrer">Evertec stock</a> opened at $20.57 on Monday. The company has a market cap of $1.48 billion, a price-to-earnings ratio of 11.36 and a beta of 0.80. The company&#8217;s 50 day moving average is $30.72 and its 200 day moving average is $32.08. Evertec Inc has a twelve month low of $19.79 and a twelve month high of $37.38. The company has a quick ratio of 1.91, a current ratio of 1.91 and a debt-to-equity ratio of 1.97. </p>
<p>Evertec (NYSE:EVTC) last issued its quarterly earnings data on Tuesday, February 25th. The business services provider reported $0.48 earnings per share for the quarter, beating the Zacks&#8217; consensus estimate of $0.45 by $0.03. Evertec had a net margin of 21.23% and a return on equity of 54.99%. The company had revenue of $127.19 million for the quarter, compared to the consensus estimate of $121.69 million. During the same quarter in the prior year, the firm earned $0.46 earnings per share. The firm&#8217;s revenue for the quarter was up 7.6% compared to the same quarter last year.  Sell-side analysts expect that  Evertec Inc will post 1.88 EPS for the current fiscal year. </p>
<p>The firm also recently disclosed a quarterly dividend, which will be paid on Friday, April 3rd. Shareholders of record on Wednesday, March 4th will be paid a $0.05 dividend. The ex-dividend date is Tuesday, March 3rd. This represents a $0.20 dividend on an annualized basis and a dividend yield of 0.97%. Evertec&#8217;s payout ratio is currently 11.05%. </p>
<p><strong>Evertec Profile</strong></p>
<p>EVERTEC, Inc engage in transaction processing business serving financial institutions, merchants, corporations, and government agencies in Latin America and the Caribbean. The company operates in four segments: Payment Services &#8211; Puerto Rico &amp; Caribbean; Payment Services &#8211; Latin America; Merchant Acquiring; and Business Solutions.</p>
<p>Featured Article: <a href='https://www.marketbeat.com/financial-terms/what-is-qqq-etf/'>What is the QQQ ETF?</a><!--ViewCount:ArticleHistoryID=49709299&PostDate=2020-3-23&type=f&id=6702364--></p>
<p style='text-align:center'><img src='https://www.marketbeat.com/scripts/SECFilingChart.ashx?Prefix=NYSE&#038;Symbol=EVTC' alt='Institutional Ownership by Quarter for Evertec (NYSE:EVTC)' title='Institutional Ownership by Quarter for Evertec (NYSE:EVTC)' /></p>
<p><!--Keyword: Evertec,NYSE:EVTC,EVTC,Business Service,SEC Filings,13F,Hedge Fund Holdings,Institutional Investor Holdings--><!--Ratings:4,1,NYSE:EVTC--></p>

			 	<!-- end inline unit -->
				<!-- end main text -->
				<!-- Invalidate Article -->
					 
				<!-- End Invalidate -->

<!--Begin Footer Opt-In-->
<p style="clear:both"><strong>Receive News &amp; Ratings for Evertec Daily</strong> - Enter your email address below to receive a concise daily summary of the latest news and analysts' ratings for Evertec and related companies with <a href="/daily-email-updates-basic/?symbol=NYSE:EVTC&c=Evertec" rel="nofollow" style="text-decoration:underline;font-weight:bold">MarketBeat.com's FREE daily email newsletter</a>.</p>
<form method="get" action="https://www.marketbeat.com/newsletter/default.aspx">
<input id="BelowPostRegistrationEmail" name="RegisterEmail" type="email" placeholder="Your Email Address" class="signup" />
<input type="hidden" id="Hidden1" name="RegistrationCode" value="Redmond Register-Footer" />
<input type="hidden" id="Hidden2" name="RegisterTicker" value="NYSE:EVTC" /><input class="button" type="submit" name="submit" onclick="return CheckEmail('BelowPostRegistrationEmail','ShowSuggestionFooter');" value="Sign-Up Now (Free)">
</form>
<div id="ShowSuggestionFooter"></div>
<!-- End Footer Opt-In -->

				</div> <!-- end: entry -->
				<!--/sse-->
				 				<!-- start article metadata -->
				 <div itemscope itemprop="image" itemtype="https://schema.org/ImageObject" style='display:none'>
 					<link itemprop="url" href="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?w=300&h=300&zc=1&src=https://www.marketbeat.com/logos/evertec-inc-logo.jpg" />
 					<meta itemprop="width" content="300">
 					<meta itemprop="height" content="300">
				 </div>
				<div itemscope itemprop="publisher" itemtype="https://schema.org/Organization" style="display:none">
 					<div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
 						<meta itemprop="url" content="https://redmondregister.com/wp-content/uploads/2020/03/redmond-register-06.png">
 						<meta itemprop="height" content="189">
						 <meta itemprop="width" content="605">
					 </div>
					<meta itemprop="name" content="Redmond Register"/>
					<meta itemprop="url" content="https://redmondregister.com" />
 				</div>
				<!-- end article metadata -->
			</article>

<!-- IMS below post -->
<div id="redmondregister_ros_belowpost_1"></div><br><br>
<!-- end IMS below post -->	

			
			<!-- end sponsored content -->
			<nav id="prevnext"><!-- previous and next article links -->
				<a href="https://redmondregister.com/2020/03/23/proshare-advisors-llc-buys-648-shares-of-dorman-products-inc-nasdaqdorm.html" rel="prev"><div class="previous"><h4>&laquo; PREVIOUS</h4><p>ProShare Advisors LLC Buys 648 Shares of Dorman Products Inc. (NASDAQ:DORM)</p></div></a>				<a href="https://redmondregister.com/2020/03/23/spx-flow-inc-nyseflow-shares-bought-by-proshare-advisors-llc.html" rel="next"><div class="next"><h4>NEXT &raquo;</h4><p>SPX Flow Inc (NYSE:FLOW) Shares Bought by ProShare Advisors LLC</p></div></a>			
			</nav><!-- end previous and next article links -->
			
		
		<div id="latest-news">
				
				<h2>You might be interested in:</h2>
			 				 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/lincoln-national-co-logo.jpg&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Advisor Group Inc. Decreases Stake in Lincoln National Co. " />
						<br/>
				 <!--end: longthumb-->
						<a href="https://redmondregister.com/2020/03/23/advisor-group-inc-decreases-stake-in-lincoln-national-co-nyselnc.html" rel="bookmark">Advisor Group Inc. Decreases Stake in Lincoln National Co. </a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/liberty-media-corp-logo.png&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Franklin Resources Inc. Has $145,000 Stake in Qurate Retail Inc Series A " />
						<br/>
				 <!--end: longthumb-->
						<a href="https://redmondregister.com/2020/03/23/franklin-resources-inc-has-145000-stake-in-qurate-retail-inc-series-a-nasdaqqrtea.html" rel="bookmark">Franklin Resources Inc. Has $145,000 Stake in Qurate Retail Inc Series A </a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/banner-co-logo.gif&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="ProShare Advisors LLC Has $327,000 Stock Holdings in Banner Co. " />
						<br/>
				 <!--end: longthumb-->
						<a href="https://redmondregister.com/2020/03/23/proshare-advisors-llc-has-327000-stock-holdings-in-banner-co-nasdaqbanr.html" rel="bookmark">ProShare Advisors LLC Has $327,000 Stock Holdings in Banner Co. </a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/callaway-golf-logo.jpg&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="ProShare Advisors LLC Increases Holdings in Callaway Golf Co " />
						<br/>
				 <!--end: longthumb-->
						<a href="https://redmondregister.com/2020/03/23/proshare-advisors-llc-increases-holdings-in-callaway-golf-co-nyseely.html" rel="bookmark">ProShare Advisors LLC Increases Holdings in Callaway Golf Co </a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/on-deck-capital-inc-logo.jpg&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Contrasting Oportun Financial  &amp; On Deck Capital " />
						<br/>
				 <!--end: longthumb-->
						<a href="https://redmondregister.com/2020/03/23/contrasting-oportun-financial-nasdaqoprt-on-deck-capital-nasdaqondk.html" rel="bookmark">Contrasting Oportun Financial  &amp; On Deck Capital </a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/four-corners-property-trust-inc-logo.jpg&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="ProShare Advisors LLC Increases Stock Position in Four Corners Property Trust Inc " />
						<br/>
				 <!--end: longthumb-->
						<a href="https://redmondregister.com/2020/03/23/proshare-advisors-llc-increases-stock-position-in-four-corners-property-trust-inc-nysefcpt.html" rel="bookmark">ProShare Advisors LLC Increases Stock Position in Four Corners Property Trust Inc </a>
				</div>
	 						</div><!-- end latest news -->

<!-- second ad spot -->

<br>
	</main> <!-- end main -->
<aside class="flex-sidebar">

<div class="flex-container">	
<div class="sidebar-section">
	
<iframe src="https://marketbeat.com/scripts/SidebarAdNewsSites.ashx" width="336" height="280" frameborder="no"></iframe>
    <br>

	
<!-- Network Wide AdSense Unit - Top Sidebar Position -->
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-9373162611283935" data-ad-slot="1875628183" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script>
<!-- End AdSense Unit -->
<br><br>
<!-- end first square unit -->

<!-- Network Wide AdSense Unit - Middle Sidebar Position -->
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-9373162611283935" data-ad-slot="9445683366" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script>
<!-- End AdSense Unit -->
<br><br>	
<!-- end second square unit -->
		
</div>	
<div class="sidebar-section">
<!-- OptIn Form -->

<!-- Start Sidebar Registration -->
    <div class="sidebar-email">
                        <h3>Daily Ratings &amp; News for Evertec</h3>
        	Complete the form below to receive the latest headlines and analysts' recommendations for Evertec with our free daily email newsletter:<br/>
        <form method="get" action="https://www.marketbeat.com/newsletter/default.aspx">
        <input id="RegisterEmailSidebar" name="RegisterEmail" type="email" placeholder="Your Email Address">
        <input type="hidden" id="Hidden1" name="RegistrationCode" value="Redmond Register-Sidebar">
        <input type="hidden" id="Hidden2" name="RegisterTicker" value="NYSE:EVTC" />        <input type="submit" name="submit" onclick="return CheckEmail('RegisterEmailSidebar', 'ShowSuggestionSidebar');" value="Subscribe Now (Free Sign-Up)" class="button" style="width:336px;height:30px">
    <div id="ShowSuggestionSidebar" style="padding-top:7px"></div>
    </form>
    </div>

<!-- End Sidebar Registration -->

<!-- ims -->
<div id="RedmondRegister_ROS_RightRail_1" class="text-center">
			<script type="text/javascript">
			apntag.anq.push(function() {
				apntag.showTag('RedmondRegister_ROS_RightRail_1');
			});
			</script>
		</div>
	<!-- end ims -->


<!-- start Recent Posts -->
        <br/>
        <div>
        <h3>Recent News</h3>
            <ul>
                        <li class="recent-posts"><a href="https://redmondregister.com/2020/03/23/advisor-group-inc-decreases-stake-in-lincoln-national-co-nyselnc.html">Advisor Group Inc. Decreases Stake in Lincoln National Co. (NYSE:LNC)</a></li>
                        <li class="recent-posts"><a href="https://redmondregister.com/2020/03/23/franklin-resources-inc-has-145000-stake-in-qurate-retail-inc-series-a-nasdaqqrtea.html">Franklin Resources Inc. Has $145,000 Stake in Qurate Retail Inc Series A (NASDAQ:QRTEA)</a></li>
                        <li class="recent-posts"><a href="https://redmondregister.com/2020/03/23/proshare-advisors-llc-has-327000-stock-holdings-in-banner-co-nasdaqbanr.html">ProShare Advisors LLC Has $327,000 Stock Holdings in Banner Co. (NASDAQ:BANR)</a></li>
                        <li class="recent-posts"><a href="https://redmondregister.com/2020/03/23/proshare-advisors-llc-increases-holdings-in-callaway-golf-co-nyseely.html">ProShare Advisors LLC Increases Holdings in Callaway Golf Co (NYSE:ELY)</a></li>
                        <li class="recent-posts"><a href="https://redmondregister.com/2020/03/23/contrasting-oportun-financial-nasdaqoprt-on-deck-capital-nasdaqondk.html">Contrasting Oportun Financial (NASDAQ:OPRT) &amp; On Deck Capital (NASDAQ:ONDK)</a></li>
                        <li class="recent-posts"><a href="https://redmondregister.com/2020/03/23/proshare-advisors-llc-increases-stock-position-in-four-corners-property-trust-inc-nysefcpt.html">ProShare Advisors LLC Increases Stock Position in Four Corners Property Trust Inc (NYSE:FCPT)</a></li>
                        <li class="recent-posts"><a href="https://redmondregister.com/2020/03/23/proshare-advisors-llc-increases-position-in-m-d-c-holdings-inc-nysemdc.html">ProShare Advisors LLC Increases Position in M.D.C. Holdings, Inc. (NYSE:MDC)</a></li>
                        <li class="recent-posts"><a href="https://redmondregister.com/2020/03/23/proshare-advisors-llc-makes-new-investment-in-alector-inc-nasdaqalec.html">ProShare Advisors LLC Makes New Investment in Alector Inc (NASDAQ:ALEC)</a></li>
                        <li class="recent-posts"><a href="https://redmondregister.com/2020/03/23/proshare-advisors-llc-makes-new-investment-in-shenandoah-telecommunications-nasdaqshen.html">ProShare Advisors LLC Makes New Investment in Shenandoah Telecommunications (NASDAQ:SHEN)</a></li>
                        <li class="recent-posts"><a href="https://redmondregister.com/2020/03/23/proshare-advisors-llc-decreases-stake-in-amphastar-pharmaceuticals-inc-nasdaqamph.html">ProShare Advisors LLC Decreases Stake in Amphastar Pharmaceuticals Inc (NASDAQ:AMPH)</a></li>
                        <li class="recent-posts"><a href="https://redmondregister.com/2020/03/23/diebold-nixdorf-nysedbd-raised-to-buy-at-zacks-investment-research.html">Diebold Nixdorf (NYSE:DBD) Raised to Buy at Zacks Investment Research</a></li>
                        <li class="recent-posts"><a href="https://redmondregister.com/2020/03/23/renaissance-technologies-llc-acquires-973100-shares-of-express-inc-nyseexpr.html">Renaissance Technologies LLC Acquires 973,100 Shares of Express, Inc. (NYSE:EXPR)</a></li>
                        <li class="recent-posts"><a href="https://redmondregister.com/2020/03/23/renaissance-technologies-llc-raises-stock-position-in-ardelyx-inc-nasdaqardx.html">Renaissance Technologies LLC Raises Stock Position in Ardelyx Inc (NASDAQ:ARDX)</a></li>
                        <li class="recent-posts"><a href="https://redmondregister.com/2020/03/23/panagora-asset-management-inc-sells-8015-shares-of-prestige-consumer-healthcare-inc-nysepbh.html">Panagora Asset Management Inc. Sells 8,015 Shares of Prestige Consumer Healthcare Inc (NYSE:PBH)</a></li>
                        <li class="recent-posts"><a href="https://redmondregister.com/2020/03/23/renaissance-technologies-llc-grows-stock-holdings-in-ttec-holdings-inc-nasdaqttec.html">Renaissance Technologies LLC Grows Stock Holdings in TTEC Holdings Inc (NASDAQ:TTEC)</a></li>
                        <li class="recent-posts"><a href="https://redmondregister.com/2020/03/23/raymond-james-financial-services-advisors-inc-sells-6191-shares-of-fidelity-nasdaq-composite-index-tracking-stock-etf-nasdaqoneq.html">Raymond James Financial Services Advisors Inc. Sells 6,191 Shares of Fidelity NASDAQ Composite Index Tracking Stock ETF (NASDAQ:ONEQ)</a></li>
                        <li class="recent-posts"><a href="https://redmondregister.com/2020/03/23/franklin-resources-inc-lowers-position-in-alarmcom-hldg-inc-nasdaqalrm.html">Franklin Resources Inc. Lowers Position in AlarmCom Hldg Inc (NASDAQ:ALRM)</a></li>
                        <li class="recent-posts"><a href="https://redmondregister.com/2020/03/23/proshare-advisors-llc-decreases-stock-holdings-in-atara-biotherapeutics-inc-nasdaqatra.html">ProShare Advisors LLC Decreases Stock Holdings in Atara Biotherapeutics Inc (NASDAQ:ATRA)</a></li>
                        <li class="recent-posts"><a href="https://redmondregister.com/2020/03/23/patterson-companies-inc-nasdaqpdco-shares-sold-by-panagora-asset-management-inc.html">Patterson Companies, Inc. (NASDAQ:PDCO) Shares Sold by Panagora Asset Management Inc.</a></li>
                        <li class="recent-posts"><a href="https://redmondregister.com/2020/03/23/proshare-advisors-llc-acquires-1514-shares-of-rhythm-pharmaceuticals-inc-nasdaqrytm.html">ProShare Advisors LLC Acquires 1,514 Shares of Rhythm Pharmaceuticals Inc (NASDAQ:RYTM)</a></li>
                        </ul>
        </div>  
</div>
</div>
<!-- end recent posts -->
</aside><!--end #sidebar-->
	<div style="clear: both;"></div>
</div> <!-- end .width-limiter -->
<footer class="full-width">
	<div class="width-limiter flex-container">
		<div id="footer-info" class="add-padding flex-nav">
			<nav class="navigation"><ul id="menu-menu-3" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18"><a href="https://redmondregister.com/headlines">Headlines</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16"><a href="https://redmondregister.com/business">Business</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17"><a href="https://redmondregister.com/economy">Economy</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19"><a href="https://redmondregister.com/health">Health</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-20"><a href="https://redmondregister.com/technology">Technology</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-14"><a href="https://redmondregister.com/about-contact">Contact</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15"><a href="https://redmondregister.com/privacy-policy">Policies</a></li>
</ul></nav>		</div><!-- end #footer-info -->
		<span id="copyright" class="add-padding flex-copyright">
				&copy; 2018-2020 <a href="https://redmondregister.com">Redmond Register</a>
	    </span>
	</div>	
	
</footer>
		<script type='text/javascript' src='https://redmondregister.com/wp-includes/js/wp-embed.min.js?ver=5.1.4'></script>
</div>

<!-- MarketBeat News Network StatCounter Code -->
<script type="text/javascript">var sc_project=9021069; var sc_invisible=1;  var sc_security="fdde5482"; var sc_https=1; </script>
<script type="text/javascript" src="https://www.statcounter.com/counter/counter.js"></script>
<noscript><img class="statcounter" src="https://c.statcounter.com/9021069/0/fdde5482/1/" height="1" width="1"></noscript>
<!-- End MarketBeat News Network StatCounter Code -->

<!-- Start of StatCounter Code for Redmond Register -->
<script type="text/javascript">
var sc_project=12002877; 
var sc_invisible=1; 
var sc_security="6999cbeb"; 
var sc_https=1; 
var scJsHost = (("https:" == document.location.protocol) ? "https://secure." : "http://www.");
</script>
<script type="text/javascript" src="https://www.statcounter.com/counter/counter.js"></script><noscript><img class="statcounter" src="//c.statcounter.com/12002877/0/6999cbeb/1/" alt="Web Analytics"></a></noscript>
<!-- End of StatCounter Code for Redmond Register -->

<!-- Begin Social Sharing -->
		<div style="top:25%;left:0;position:fixed;width:50px;z-index:20;box-sizing:content-box;" class="mobile-hide">
	<div style="background-color:#305891;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://www.facebook.com/sharer/sharer.php?u=https://redmondregister.com/2020/03/23/proshare-advisors-llc-acquires-1514-shares-of-rhythm-pharmaceuticals-inc-nasdaqrytm.html" target="_blank"><img src="/images/social-fb.png" style="margin:0;padding:0;" alt="share news on Facebook"></a></div>
	<div style="background-color:#2CA8D2;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://twitter.com/intent/tweet?text=ProShare Advisors LLC Acquires 1,514 Shares of Rhythm Pharmaceuticals Inc $NASDAQ:RYTM https://redmondregister.com/2020/03/23/proshare-advisors-llc-acquires-1514-shares-of-rhythm-pharmaceuticals-inc-nasdaqrytm.html" target="_blank"><img src="/images/social-tw.png" style="margin:0;padding:0;" alt="tweet this investment news"></a></div>
	<div style="background-color:#007BB6;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://www.linkedin.com/cws/share?mini=true&url=https://redmondregister.com/2020/03/23/proshare-advisors-llc-acquires-1514-shares-of-rhythm-pharmaceuticals-inc-nasdaqrytm.html" target="_blank"><img src="/images/social-in.png" style="margin:0;padding:0;" alt="share on linkedin"></a></div>
	<div style="background-color:#89120a;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://api.stocktwits.com/widgets/share?via=AnalystRatingsNetwork&body=ProShare Advisors LLC Acquires 1,514 Shares of Rhythm Pharmaceuticals Inc $NASDAQ:RYTM https://redmondregister.com/2020/03/23/proshare-advisors-llc-acquires-1514-shares-of-rhythm-pharmaceuticals-inc-nasdaqrytm.html" target="_blank"><img src="/images/social-st.png" style="margin:0;padding:0;box-sizing:content-box;" alt="share on StockTwits"></a></div>
	<div style="background-color:#FF1A00;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://www.reddit.com/submit?url=https://redmondregister.com/2020/03/23/proshare-advisors-llc-acquires-1514-shares-of-rhythm-pharmaceuticals-inc-nasdaqrytm.html&title=ProShare Advisors LLC Acquires 1,514 Shares of Rhythm Pharmaceuticals Inc (NASDAQ:RYTM)" target="_blank"><img src="/images/social-reddit.png" style="margin:0;padding:0;" alt="share on reddit"></a></div>
	</div>
	<!-- End Social Sharing -->

<!-- Begin Internal Tracking Pixel 2 -->
<script type='text/javascript'>document.write('<img src="https://www.american' + 'consumernews.net/scripts/viewcount.ashx?ArticleHistoryID=49709499&PostDate=2020-3-23&type=f&id=6702418&domain=redmondregister.com&referrer=' + encodeURIComponent(document.referrer) + '" />');</script>
<!-- End Internal Tracking Pixel 2-->



	</body>
</html>
